Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Excel formula conta.se intervalli variabili da valore cella

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Excel formula conta.se intervalli variabili da valore cella

Postdi Statix » 24/05/21 15:22

Ciao a tutti,ho un problema a trovare una formula,
ho un range di 1620 righe D7:H1626
in una cella B1=10
in questo caso la formula sarà
Codice: Seleziona tutto
=conta.se(D7:H16;1)

se cambio il valore in B1 esempio 15
Codice: Seleziona tutto
la formula sarà =conta.se(D7:H21;1)

quindi vorrei che la formula varia il range di conta.se in base alla cella B1,
con il vba ci riesco con una variabile,
a me serve una formula.
grazie
Statix
Windows 10,
Office 2013,
Statix
Utente Senior
 
Post: 1287
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta

Sponsor
 

Re: Excel formula conta.se intervalli variabili da valore ce

Postdi Marius44 » 24/05/21 16:48

Ciao
Premetto che non sono un esperto di formule ma mi piace cimentarmi.
Prova con questa formula
=SOMMA(D1:INDICE(D1:D18;CONFRONTA(B2;D1:D18;0)))

Ho inserito i numeri da sommare nella colonna D e la riga fino alla quale sommare nella cella B2

Fai sapere. Ciao,
Mario
Marius44
Utente Senior
 
Post: 568
Iscritto il: 07/09/15 22:00

Re: Excel formula conta.se intervalli variabili da valore ce

Postdi Statix » 24/05/21 16:54

ciao Marius44,
adesso su questo computer non ho office quindi non posso provare, ma direi ad occhio la formula non è quella che cerco,
la formula deve fare un conta.se è non una somma inoltre i riferimenti sono diversi,
già tempo fa ho chiesto una cosa simile sul forum ma non riesco più a ricordarmelo su quale post,
se non erro usava scarto con dei rif.riga(),
spero di riuscirla a trovarla, nel frattempo vediamo
Statix
Windows 10,
Office 2013,
Statix
Utente Senior
 
Post: 1287
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta

Re: Excel formula conta.se intervalli variabili da valore ce

Postdi Anthony47 » 24/05/21 16:59

Forse questa?
Codice: Seleziona tutto
=CONTA.SE(SCARTO(D7;0;0;B1;7);1)


Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 17865
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Excel formula conta.se intervalli variabili da valore ce

Postdi Statix » 24/05/21 17:12

ciao Anthony sembra che funziona ,come mai quando clicco la formula vedo solo la prima cella D7 e non il range
Statix
Windows 10,
Office 2013,
Statix
Utente Senior
 
Post: 1287
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta

Re: Excel formula conta.se intervalli variabili da valore ce

Postdi Statix » 24/05/21 17:15

la formula conta anche la colonna J
il range va da D: H
Statix
Windows 10,
Office 2013,
Statix
Utente Senior
 
Post: 1287
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta

Re: Excel formula conta.se intervalli variabili da valore ce

Postdi Statix » 24/05/21 17:31

ho corretto la formula contava 2 colonne in più

Codice: Seleziona tutto
=CONTA.SE(SCARTO(D7;0;0;B1;5);1)
Statix
Windows 10,
Office 2013,
Statix
Utente Senior
 
Post: 1287
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta

Re: Excel formula conta.se intervalli variabili da valore ce

Postdi Anthony47 » 24/05/21 20:24

ho corretto la formula contava 2 colonne in più
E pensare che avevo contato sulle dita :D :D

come mai quando clicco la formula vedo solo la prima cella D7 e non il range
Perche' solo D7 e' "predecessore" della formula; B1 e tutto il resto sono "parametri"

Alla prossima...
Avatar utente
Anthony47
Moderatore
 
Post: 17865
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "Excel formula conta.se intervalli variabili da valore cella":


Chi c’è in linea

Visitano il forum: Nessuno e 37 ospiti