Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Inserire la funzione INDIRETTO

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Inserire la funzione INDIRETTO

Postdi T.Life » 18/07/21 11:26

Salve !!!
Vorrei chiedervi la cortesia di inserire la funzione INDIRETTO su queste due formule

=CONTA.SE($B$1:$G$50;BM19)

=SOMMA(--(MATR.PRODOTTO(CONTA.SE($BM3:$BN3;$B$1:$G$50);RIF.RIGA($BL$3:$BL$8)^0)=2))
T.Life
Utente Junior
 
Post: 36
Iscritto il: 22/09/12 13:44

Sponsor
 

Re: Inserire la funzione INDIRETTO

Postdi Anthony47 » 18/07/21 12:27

Indiretto restituisce un Indirizzo, vedi https://support.microsoft.com/it-it/off ... b6306fa261
Come usarlo all'interno delle tue formule dipende da cosa vuoi portare fuori dalla dalla formula; ad esempio, partendo dalla tua =SOMMA(--(MATR.PRODOTTO(CONTA.SE($BM3:$BN3;$B$1:$G$50);RIF.RIGA($BL$3:$BL$8)^0)=2))

queste alternative sono equivalenti:
=SOMMA(--(MATR.PRODOTTO(CONTA.SE(INDIRETTO(I10);$B$1:$G$50);RIF.RIGA($BL$3:$BL$8)^0)=2)) se I10 contiene BM3:BN3
=SOMMA(--(MATR.PRODOTTO(CONTA.SE(INDIRETTO("$BM3:"&I11);$B$1:$G$50);RIF.RIGA($BL$3:$BL$8)^0)=2)) se I11 contiene BN3
=SOMMA(--(MATR.PRODOTTO(CONTA.SE($BM3:$BN3;INDIRETTO("$B$1:$G$" &I12));RIF.RIGA($BL$3:$BL$8)^0)=2)) se I12 contiene 50

Spero che questi esempi ti diano lo spunto per la formula che serve a te

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 17865
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Inserire la funzione INDIRETTO

Postdi T.Life » 18/07/21 19:05

Queste due formule interagiscono su un database, il quale viene aggiornato ogni volta aggiungendo una riga.
Da li parte l'esigenza di avere delle formule che non cambino i riferimenti di cella per non riaggiornarli.
T.Life
Utente Junior
 
Post: 36
Iscritto il: 22/09/12 13:44

Re: Inserire la funzione INDIRETTO

Postdi Anthony47 » 18/07/21 21:51

Quindi puoi usare Indiretto come nel terzo esempio, solo che in I12 (o dove vuoi tu) metterai una formula che conta qual'e' l'utima riga usata in B1:G1000; esempio:
Codice: Seleziona tutto
=MAX((B1:G1000<>"")*RIF.RIGA(B1:B1000))

Da confermare con Contr-Maiusc-Enter, non il solo Enter

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 17865
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "Inserire la funzione INDIRETTO":


Chi c’è in linea

Visitano il forum: Nessuno e 50 ospiti