Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

numero valori univoci con condizione

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

numero valori univoci con condizione

Postdi marcoc » 22/11/22 15:50

ciao a tutti,
semplificando il mio caso, ho in col.A il nome del venditore e in col.B il nome del cliente, che si ripete su più righe.

Usando la formula
=SOMMA(1/CONTA.PIÙ.SE(B2:B100;B2:B100))
mi conta il numero di valori univoci (numero clienti) totale.

Come posso integrarla, considerando anche la col.A, ovvero ottenere il numero clienti univoci per venditore?

grazie e buona giornata
Avatar utente
marcoc
Utente Senior
 
Post: 317
Iscritto il: 22/03/07 21:58
Località: Nerviano

Sponsor
 

Re: numero valori univoci con condizione

Postdi wallace&gromit » 22/11/22 17:36

Mi sembra un lavoro da fare con le tabelle pivot, lì puoi gestire i sottogruppi per ogni venditore.
Office2016 + 2019 su win11
Avatar utente
wallace&gromit
Utente Senior
 
Post: 2128
Iscritto il: 16/01/12 14:21

Re: numero valori univoci con condizione

Postdi Anthony47 » 22/11/22 19:28

Non mi pare che tu disponga di Office 365 oppure Office 2021 (che contengono funzioni utilissime anche per questi calcoli); quindi il suggerimento "Tabella pivot" che ti ha gia' dato W&G e' anche il mio preferito.
Anche perche' probabilmente oltre a sapere quanti ti interesserà anche riepilogare altre informazioni (es quanti ordini per quanto valore)

Ciao a tutti
Avatar utente
Anthony47
Moderatore
 
Post: 18661
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: numero valori univoci con condizione

Postdi marcoc » 23/11/22 16:20

ciao Anthony,
a casa no, ma sul pc del lavoro ho office 365.
qual è la formula che dici?
Avatar utente
marcoc
Utente Senior
 
Post: 317
Iscritto il: 22/03/07 21:58
Località: Nerviano

Re: numero valori univoci con condizione

Postdi Anthony47 » 23/11/22 18:10

Con riferimento alla figura
Immagine

In D3 crei l'elenco dei Venditori con la formula
Codice: Seleziona tutto
=UNICI(FILTRO(A2:A20;A2:A20<>""))
(la formula si espande sulle celle sottostanti "quanto basta")

In E2 calcoli il num dei Clienti del primo venditore con la formula
Codice: Seleziona tutto
=SE(D2<>"";CONTA.VALORI(UNICI(FILTRO($B$2:$B$20;$A$2:$A$20=D2)));"")
Copia verso il basso per gli altri venditori

Se ti interessa, in F2 crei l'elenco dei Clienti con la formula
Codice: Seleziona tutto
=TESTO.UNISCI(", ";VERO;UNICI(FILTRO($B$2:$B$20;$A$2:$A$20=D2)))
Copia verso il basso per gli altri venditori

Valide solo pe versioni di Office che supportano gli "Array dinamici" (365 e credo 2021)
Avatar utente
Anthony47
Moderatore
 
Post: 18661
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: numero valori univoci con condizione

Postdi marcoc » 24/11/22 14:18

ottimo!
Avatar utente
marcoc
Utente Senior
 
Post: 317
Iscritto il: 22/03/07 21:58
Località: Nerviano


Torna a Applicazioni Office Windows


Topic correlati a "numero valori univoci con condizione":


Chi c’è in linea

Visitano il forum: Nessuno e 27 ospiti