Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

excel 2003: confrontare dati di due colonne

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

excel 2003: confrontare dati di due colonne

Postdi gamma_ray » 14/12/21 14:45

Ho un documento chiamato INDIRIZZI in cui nella colonna A ci sono circa 21000 indirizzi mail.
In un altro documento chiamto INDESIDERATI ho una colonna con circa 120 indirizzi mail indesiderati.
C'è un modo veloce con una formula per individuare immediatamente gli indirizzi indesiderati, filtrarli e cancellarli in un colpo?
Grazie.
Avatar utente
gamma_ray
Utente Senior
 
Post: 1555
Iscritto il: 09/05/03 16:27

Sponsor
 

Re: excel 2003: confrontare dati di due colonne

Postdi Anthony47 » 14/12/21 17:27

Usa in una colonna libera del file principale la funzione CONTA.SE per vedere se quell'indirizzo esiste nel secondo file.
Copia su tutte le 21mila celle sottostanti.
Infine filtra quella colonna per visualizzare tutti i valori >0, seleziona tutte le righe visibili e cancellarle.

Fai sapere se così risolvi
Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 18264
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: excel 2003: confrontare dati di due colonne

Postdi gamma_ray » 14/12/21 17:58

Mi sa che non ho capito...quando uso la funzione conta.se mi chiede di selezionare l'intervallo, e io seleziono gli indirizzi da a1 ad a21000 circa. Ma poi nel campo criteri cosa devo selezionare?
Avatar utente
gamma_ray
Utente Senior
 
Post: 1555
Iscritto il: 09/05/03 16:27

Re: excel 2003: confrontare dati di due colonne

Postdi Anthony47 » 14/12/21 18:09

No, devi indicare l'intervallo sul secondo file, e come criterio scriverai la cella A1.
In pratica:
-scrivi =CONTA.SE( nella barra della formula
-vai sul secondo file e seleziona l'intervallo
-metti il punto-e-virgola, scrivi A1
-completi con la) di chiusura e con Enter
-poi copia verso il basso

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 18264
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: excel 2003: confrontare dati di due colonne

Postdi gamma_ray » 14/12/21 18:26

Abbi pazienza ma non ho capito... :oops:
Allora vado in una cella vuota in una colonna del primo file e scrivo =CONTA.SE
Ma poi se vado sul secondo file e seleziono la colonna, non succede niente, mi perdo qualcosa...
Avatar utente
gamma_ray
Utente Senior
 
Post: 1555
Iscritto il: 09/05/03 16:27

Re: excel 2003: confrontare dati di due colonne

Postdi Anthony47 » 14/12/21 19:46

Diamo per scontato che i due file siano aperti nella stessa sessione di Excel

Nel file AAA.xlsx hai occupate le celle A1:A21000 e nel file BBB hai occupate le celle A1:A120
-Vai in cella G1 di AAA (supponendo che colonna G sia libera) e cominci a scrivere =CONTA.SE(
-Ora selezioni il file BBB, selezioni il foglio giusto (supponiamo Foglio1), selezioni l'area A1:A120
-in questa situazione nella barra dell formula dovresti leggere =CONTA.SE([BBB.xlsx]Foglio1!$A$1:$A$120 (nota1)
-aggiungi nella formula ;A1) e completi con Enter
Ora la formula dovrebbe essere del tipo =CONTA.SE([BBB.xlsx]Foglio1!$A$1:$A$120;A1) e dovrebbe dirti se l'indirizzo presente in A1 del foglio AAA e' presente nell'elenco degli indesiderati
Copia la cella G1 verso il basso e così dovresti avere 1 negli indirizzi presenti nell'elenco degli indesiderati

Nota1: se invece a quel punto non vedi quella formula allora probabilmente i due file sono aperti in due sessioni diverse di Excel: chiudi il file BBB.xlsx; vai dove vedi il file AAA.xlsx aperto; con Menu /File /Apri apri il file BBB.xlsx e riprova

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 18264
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: excel 2003: confrontare dati di due colonne

Postdi gamma_ray » 14/12/21 21:01

ok sono riuscito a inserire la formula, solo che il risultato è sempre zero.
Dove sbaglio?
Avatar utente
gamma_ray
Utente Senior
 
Post: 1555
Iscritto il: 09/05/03 16:27

Re: excel 2003: confrontare dati di due colonne

Postdi Anthony47 » 14/12/21 21:32

Non sbagli, ma evidentemente c'e' qualcosa che rende non uguali due stringhe che sembrano uguali; probabilmente uno spazio in fondo a qualcuno degli elenchi, che elimini con un Trova e Sostituisci (trova lo Spazio, sostituisci con niente)

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 18264
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: excel 2003: confrontare dati di due colonne

Postdi gamma_ray » 15/12/21 09:29

Anthony47 ha scritto:Non sbagli, ma evidentemente c'e' qualcosa che rende non uguali due stringhe che sembrano uguali; probabilmente uno spazio in fondo a qualcuno degli elenchi, che elimini con un Trova e Sostituisci (trova lo Spazio, sostituisci con niente)

Ciao


Cioè in pratica scrivo Spazio dentro sostituisci e poi sotto non scrivo niente giusto?
Ho fatto così, mi ha fatto 5 sostituzioni ma il risultato è sempre zero.
Avatar utente
gamma_ray
Utente Senior
 
Post: 1555
Iscritto il: 09/05/03 16:27

Re: excel 2003: confrontare dati di due colonne

Postdi Anthony47 » 15/12/21 13:52

La procedura di Trova e Sostituisci e' quella, devi farla sia sull'elenco da 21mila che quello piu' breve.

Per evitare equivoci dimmi la formula che hai usato.
Poi aggiungi un indirizzo all'elenco dei 21mila e metti lo stesso indirizzo nell'elenco degli indesiderati, adattando la formula se necessario (lunghezza dell'intervallo degli Indesiderati); controlla che la formula restituisca 1 e non 0

Comunque devi debuggare perche' su un indirizzo dei 21mila che sia presente anche negli Indesiderati la formula ti restituisca 0; se le voci sono state prelevate da pagine web non e' escluso che ci siano caratteri simili allo spazio ma NON esattamente spazio (il cosiddetto nbsp, chr(160)), ma e' una cosa che puoi debuggare solo tu sui tuoi elenchi
Oppure pubblica un file dimostrativo indicando dove dovrebbe comparire 1 ma invece compare 0

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 18264
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: excel 2003: confrontare dati di due colonne

Postdi gamma_ray » 23/12/21 08:57

Rieccomi...niente alla fine non ce l'ho fatta e ho rinunciato all'eliminazione degli indirizzi della blacklist.
Ti volevo però ringraziare per l'aiuto.
Alla prossima.
Avatar utente
gamma_ray
Utente Senior
 
Post: 1555
Iscritto il: 09/05/03 16:27

Re: excel 2003: confrontare dati di due colonne

Postdi Anthony47 » 23/12/21 11:11

Grazie per il feedback
Mi spiace che non sia riuscito a trovare l'inghippo, ma non disponendo del tuo set di dati non sono in grado di fare di piu'
Eventualmente potresti individuare un paio di indirizzi che dovrebbero essere identificati e creare un file ridotto contenente solo questi indirizzi; vedi tu se e' possibile

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 18264
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "excel 2003: confrontare dati di due colonne":


Chi c’è in linea

Visitano il forum: Nessuno e 46 ospiti